ubuntu安装matplotlib

(可恶,git用的不熟练,把commit丢了…重写文章)

总结一下,在安装了NumPy之后还需要安装

  1. freetype
  2. libpng
  3. libffi
  4. cairocffi

freetype 下载地址 http://download.savannah.gnu.org/releases/freetype/

wget http://download.savannah.gnu.org/releases/freetype/freetype-2.6.5.tar.gz
tar xvf freetype-2.6.5
sudo make
sudo make install

libpng和libffi都在apt上有

➜  artic git:(master) ✗ search libffi
libffi-dev - Foreign Function Interface library (development files)
➜  artic git:(master) ✗ search libpng
libpng12-0 - PNG library - runtime
libpng12-dev - PNG library - development

直接apt-get安装即可

调用matplotlib的时候图像式全黑的,提示我安装cairocffi,是pip上的包,安装了第三个之后直接pip安装这个就可以了.